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JCreator

JCreator is a commercial Java environment available from http://www.jcreator.com. Inexpensive academic licenses
and a free "limited edition" are available. JCreator runs only on Microsoft Windows.

This document describes JCreator 2.50.

Starting JCreator

When you start JCreator, you get a screen such as this one:

1o/
J File Edit Search ‘iew Project Build Tools Configure Help

A SEHF| % BB ] 4% %% H B ==]e > .
ERBOE | RBEE | A LAAALLALAEAA54 B BD|EL- & 200 -

Mo workspace loaded

ClazsYiew not available

Far Help, press F1 v

Before going any further, it is a good idea to set preferences for the Java editor that match the conventions of the
textbook. Select Configure->Options from the menu. Select Documents->Java from the tree in the left panel.
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Options x|
- General _ Optiong for java documents
- Editor

=- D:cu:uments —Tabs — Indent brackets —End of line
- Java
2l Plain £ Inzeit tabs v autoindent ¥ Auto
El- Html " |nzert spaces " Nao i DOs
[+ Drefault
- Diirectaries Size: I:{ e ANS| style LN
- JOK, Profiles ' ~ ~
- JDK Taok Show tabs GMHU style MALC
- Waorkspace ~ Compatibility
- Code Inzertion : )
.. Code Completion ¥ Show line numbers ¥ Backspace at start of line
- Code Templates V¥ Show selection margin ™ Tiim krailing spaces
- Toolz
FI|E .&.SSDCiatiDns E:.:tensigns: Iiava
Encoding: IN::: encoding j
(] I Cancel Apply | Help |

Then check the radio button Inserts spaces and set the Tab Size to 3. (The JCreator default is 4.)

Next, choose Workspace->Code Insertion from the tree.

Ix

- General

- Editor

=~ Documents
-- Java
- Plain v ‘Start open brace on new line.;
= Html
B Defaul V¥ Inzert TODO text

- Dlirectones

- JOK. Profiles

- JOK. Toolz

[+ " orkspace

- Code Inzertion

- Code Completion

- Code Templates

- Tools

- File Azzociations

[” Space before left parentheses

ak. I Cancel Apply Help

Check the box Start open brace on new line.

Finally, click Ok to save your settings.

Loading an existing program
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If you already have your program in a Java file (or a directory containing multiple Java files), then you need to make
a project that contains the file. Follow these steps.

Select Project->New Project from the menu. You will get the following dialog.

Hew x|

Filez  Projects |"-.r‘-.-"u:urkspa|:e3 I

Project name:
I Iz Ic |purse

Basic Java BasicJava  Empty Project
Application Applet

Lacation:
|E:Hbigiava\ch03hpurse J

{* Create new workspace

) Sdd to curent workspace

Ok I Cancel Help

Give a name to the project. The best choice for the name is the name of the directory that contains the files. For
example, if Purse. java and PurseTest. java are located inside a directory purse, call the project purse.

Edit the Location field so that it contains the full directory path of your program files, such as
c:\bigjava\ch03\purse. Click on the Ok button.

CAUTION: When creating a new project, JCreator wants to create a file with the same name as the project name
(such as purse. java). However, if you load an existing set of files, chances are good that there is already a file with
that name. In that case, you get a dialog such as the following.

Confirm File Overwrite |
Replace File: C:AbigiavahchO3spurzehPurze. java
1KB  04/08/03 16:43:44
@ Mew File : Purze.java

Yes to Al Mo Cancel

Be sure to choose No! You don't want the existing file replaced with an empty file.

Usually, the project directory contains other useful files (such as PurseTest. java) that need to become part of the
project as well.

To include these files, select Project->Add files from the menu. Locate the files that you want to add.

(You can select multiple files in the file dialog with the CTRL+Click combination, or you can repeat this process
multiple times.)

The files are added to the project window. Double-click on a file to bring up an editor window.

T T T T T iml el
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Al L=y oy
JB File Edit Search Miew Project Build Tools Corfigure ‘Window Help =|i|5|
I EE e "B |ES e .
BEGEB BEE |4 44LAA5454 0 BB BS & LD .
S T 1 IIJ'I** —
@WﬂkaPECE'PUTSE'11PfDiECt 2 A purse computes the total value of a collection of —
=-E purse 3 %/
e uise ava 4 public class Purse
b PurzeTest java 5 {
G r,."**
7 Constructs an empty purse.
8 *f
g public Pursel() b
10 {
11 nickels = 0;
12 dimes = 0;
13 guarters = 0;
= 14 }
=-%8 Purse - 15
----- % Purze ) 16 fre
""" % addDimes [int count] 17 Add nickels to the purse.
""" % addNickels (int count] 18 @param count the number of nickels to add
----- % adduarters [int count 14a *f
""" % getTotal ) 20 public void addMNickels{int count)
----- @ DIME_VALUE = 21 {
""" @ MICKEL_WALLIE 22 nickels = nickels + count; -
----- B¢ [UARTER_VALUE [ | b
..... 23 dimes r
1| e | » [ Purse java I

For Help, press F1

[Lri 1, Ciol 1, Char 1

Los | [ | 4

Starting a new program

If you write a program from scratch, then you can start your work in JCreator. It is always best to place each of your
programs into a separate directory. JCreator will create the directory for you.

Select Project->New Project from

In the dialog, give a name to the project. The best choice for the name is the name of the directory that contains the
files. For example, if your homework files are contained inside a directory hwi, call the project hwi.

Edit the Location field so that it contains the full directory path of your program files, such as c:\homework\hw1.

Filez  Projects |Wnrkspaces |

x|

J Project name:
I I Ic Ihw'l

Basic Java Ermpty Project
Application

Basic Java

Applet Location:

Iu::'\hu:umewu:urk'\hw'l

{ Create new warkspace

f* Add to curent workspace
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o ]

Cancel

Help |

Click on the Ok button.

Your project is opened. JCreator adds a Java file with the same name as the project, such as Hw1.java. If you don't
need that file, click on it in the project window and select Edit->Delete from the menu.

To add a new class to the project, choose Project->New class from the menu. You get a dialog such as the

x|

-]

[

=L

following:
ClazsWizard
Clazz name : |HEII|:|
Ly Source location : |E:'xhc:mewu:urk'xhw1'x
Ll .
o Clazs Properties | M ethods Y ariables
= Baze claszs Iiava_lang.Dbiect
o2
I Package : |
Interface
— Clazz options :
™ Fublc
[ fbstract
[ FEinal

[T Dvenide abstract methads
[~ Generate default constructar

[™ Generate main method

Ok I Cancel

Help |

Fill in the name of the class (such as Hel1o). A new file (such as Hello. java) is added to the project.

Now you can type your program into the source window. Note the code completion feature that suggests how to
complete partially typed expressions.

W oo =] N e B

IEN

{

class Hello

public static void main(Stringl]

{

System. out.|

% checkError ()
% close ()

% equals (Ohject)
% flush )

% getClass ()

% hashCode ()

B nokify O

@ notifyal O

% print {char[]}

[97 ‘wordTest.java | [4] Purseja % print (double)

args)

boolean ~
void
boolean
woid
Class
int
wiid
woid
void

vuidLI

B

:u.ia\-'a“l 4| "I
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Compiling a program

You will usually have multiple projects open in JCreator. When you are ready to compile and run a program, make

sure that the project on which you are working is the active project. Select Project->Active Project, and then select
your current project from the submenu.

To compile a program, select Build->Compile Project or hit the F7 key.

Compilation errors are displayed in a separate window.

hw1 - JCreator - [Hello_jawa] _|I:I|£|
Jm File Edit Search Miew Project Build Tools Corfigure Window Help ;lilﬁl
[Bledd s 2oz e%%%]|n 'fﬁ«pIE§=|4--rv
£-H- s DD .
! =
E Workspace 'purse’ 2 Projects 2 olass Hellao
EHE hw1 3 |
- ~[E] Hellojava 4 public static void main(Strings[] args)
- ~[E] Hwljava 5 {
@ purse & system.out.println("Hello, World!");
7 }
8}
9
-
=-#2 Hella
1< _>I_I
|B Hello.jawva I
3: Configuration: hwl — j2=dkl 4.0 <Default: “
C:~homework~hwl~Hello. java:4: cannot resolve symbol
=zymbol class Strings
location: class Hello
public static woid main(String=s[] args)
o [+ [ Build  Output 3 Debug » FindinFiles 1 5 Findinfiles2 «  [|4] | 3
For Help, press F1 |Lr B, Col 43, Char 43 | | [MAC | | | v

Running a program

When the program compiles successfully, you can run it. Select Build->Execute Project or hit the F5 key. The
program executes in a separate console window.

=10 x|

Jm File Edit Search “iew Project Build Tools Configure  Window  Help == x]
]?i%|ui-"ﬂﬁ|%é| ...... |,4%'%E%|nﬁ *fﬁ«ﬁ|=§§=|4--*v
R 2D E .

;Iglzlﬁ
E%mm sEEEEERN =
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[ [ Build & Output » Debug > Findin Files 1 % FindinFiles 27

led_|

For Help, press F1 Ln 9, Col 1, Char 1 kAL

Running applets

To run an applet, you must select Basic Java applet in the project dialog when you first create the project. As with

applications, you add files or classes to your project.

JCreator produces an HTML file for your applet. You should use that file (with extension .htm), and not the HTML

file that may be provided with an existing project.

Sometimes, JCreator guesses the wrong name for the applet class, and you need to fix it in the HTML file. For

example, here we change the class to carApplet.class. (JCreator guessed Car.class.)

car - JCreator - [Car.htm]
|ﬂ File Edit Search YWew Project | Buld Tools Configure  indow Help

g = Ha DA a4 - @ %

i
i
|
+

=101 %]
=18

-

BELEE B A AAAAE AR B DD DR R
- <HTML >
- car -] <HEAD >
[E] Carhtm </HEAD =
|E] Car.java <BODY BGCOLOR="000000"=
|E] Cartpplet.java J <CENTER =
15 bt <APPLET
-3 purse code = "Carfpplet] class"
-5 Enternal Files ﬂ width = "gQpQn
= height m3agaon
=
- Imparts </BAPPLET>
—- B8 Carfpplet </ CENTER >
% paint [Graphics g) </BODY =
</ HTML =
|ﬂ Hello.java |ﬂ Car. Kt ||J_1 Carjava I |ﬂ Cardpplet. bl *

Configuration: car — j2=dkl. 4.0 <Default:
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FProcess conpleted.

i [+ [+ Build  Output » Debug » FindinFiles 1 Findinfiles2 « 14 |

PI
|Ln 7, Col 25, Char 19 | | bos || | A
After compiling the project, select the menu option Build->Execute Project. JCreator will launch the applet viewer.
car - JCreator - [Car.htm] - 0] x|
J B File Edit Search Miew Project Build Tools Corfigure Window Help ;lilﬁl
| sHE Rl e 4% %% A @ EE| e .
ITT|S Appict Viewer: Carpplet class 1ol x]
I e Sox|mE -
_I_ pple
E |l
__
..
e —
=8 —
—
’ Applet started.
L L UM LT LTl
o [+ [ Build  Output 3 Debug » FindinFiles 1 5 Findinfiles2 «  [|4] | 3
For Help, press F1 |Lr 7. Col 25, Char 19 | | Dos | | | v
Running the debugger

To use the debugger, you first need to change a compiler setting. Select Configure->Options from the menu and
select Documents->JDK Tools from the tree selector in the left of the dialog.
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Options x|

- Editor

=) Documents
-- Java
- Plain
-- Htrnl <Default:
- Default

- Directories

DK Profiles

- JDK Tooks d

[+ "workspace |

- Code Inzertion

- Code Completion

- Code Templates

- Toolz

- File Aszociations

Select Tool Type: I Cormnpiler j

(] | Cancel | Apply | Help |

Highlight <Default> and click the Edit button. You get the following dialog:

Tool Configuration : Compiler il

M arne : |<Default>

Comrand ~— Parameters |

Farameters : |-g -clazspath "$[ClazsPath]” -d "$[0utputPath]* $[) avaF ﬂ

[ Show additional compilerinfio W Use class-path

¥ Show warnings [
[ Show deprecations [ Optimize code
¥ Use output path ¥ Compile all files

Ok I Cancel | Help |

Click the checkbox Include debug info and click the Ok button. Recompile your project.

Select the menu option Build->Start Debugger. The debugger starts the program and pauses at the first line in main.
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debugger - JCreator - PwfordT est_jay¥al - |EI|5|
JB File Edit Search Mew Project Build Tools Configure  Window Help ;lilﬁl
[a|lcdd|r2R|oc] 6% %% M By EE e

R w an sy g a e w Al -NI=N="N 1= 2 B4

|R

22 .

== ===

-

.
*
+
>

x
4
‘E car - 5 This program tests the countSyllables method of the
=-i] debugger & %/
- [F) wordjava 7 public class WordTest
wiordT est java g {
@ b1 g public static void main{String[] args)
{E pLIrse 10 {
== Estemal Files hd 11 String input
x 12 = JOptionPane.showInputDialog("Enter a sentenc
13 StringTokenizer tokenizer = new StringTokenizer(i
(- Imports 14 wvhile (tokenizer.hasMoreTckens(])
=-®8 WordT est 15 {
== % main [String(] args] 16 String token = tokenizer.nextTokent);
17 Word w = new Word({token) ;
[ |

B Hello.java | B Car.htrn | B Carjava | E Cardpplet. bkl | B Purze.java B WwiordT est.java

#

YH Started: Set deferred breakpoint WordTest mainijava-lang-String[])
Breakpoint hit: "thread=main", WordTest main{). line=11 bci=0

main[1l]

[+ J5 Build_, Output  Debug 4 Find in Files 1 3, FindinFiles 2 /[ 4

Thae o b

For Help, press F1 |Lr 11, Col 1. Char 1 | | |pos | |

Whenever you select the menu option Build->Step (or the F10 keyboard shortcut), then the debugger executes one
line of the program, without stepping inside method calls. For example, tracing over the call

Word w = new Word(token);
will not trace inside the word constructor but simply run the program to the next line of the main method.

Contrast that with the menu option Build->Step Into (or the F11 keyboard shortcut). This command traces inside
method calls. For example, tracing into the line

int syllables = w.countSyllables();

stops at the first line of the countSyllables method:

debugger - JCreator - [Word.java] =10 =]

JB File Edit Search Wiew Project Build Tools Configure window Help =15l

||| s=a]oc].e% %% n * B EE|[E s .

EEROB|BEE AL LA LA LLA 4B BEREBEL- L 5|00 -
.' = & 33 T j

: Workspace 'purse’ 4 Projects - 33 Counts the syllables in the word.

- car 34 ereturn the syllable count

- debugger 3L */

- [F wordjava 36 public int countSyllables()

wiordT est java 37 {

@ bl bag | int count = 0;

-3 purse [ 39 int end = text.length() - 1;
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 x 40 if (end <« 0) returmn 0; // the empty string has no—
41
E"ﬁ Wwiord 42 // an e at the end of the word doesn't count as a
e 4 Word [Shiing 3] 43 char ch = Character.toLowerCase(text.charkt (end])
----- % countSyllables [) 44 if (ch == 'e') end--;
o g getText[) 45 =
e B tewt |4| I _bl—l

B Car htm | B Car java | B Cartspplet himl | B Purze java | B WiordT ezt java B ‘wiord.java | i | bI
=
; =

main[l] =step
#
Step completed: "thread=main". Word.countSyllable=(). line=38 bci=0

main[1]
-
« [ J% Build_, Output » Debug 4 Find in Files 1 3, Findin Files 2 /7 [ 4 ;

For Help, press F1 |Ln 38, Cal 1, Char 1 | | oos || | v

Often, it is tedious to step through the program a line at a time. In that case, set breakpoints at interesting program
locations. To set a breakpoint at a line, move the cursor into the line and select the menu option
Build->Debugger->Toggle breakpoint, or hit the F9 key. A red dot indicates the breakpoint.

50 String vowels = "aeiouy"; ZI
51 if (vowels.indexOf (ch] == 0]

52 {

E3 J/ ch i a wawel

54 if (!insideVowelGroup)

55 {

1 // start of new vowel group
17 | count++;

53 insideVowelGroup = true;

59 }

60 } J
61 }

62

IEEi // every word has at least one syllablel -
4 v

B Car.htm | B Car.java | B Cartupplet. htrl | B Purze.java | B YWoordT est.java B ‘wiord.java | 1 | lrI

You can set as many breakpoints as you like.

Then select Build->Continue from the menu. The program runs at full speed and stops at any breakpoints that it
encounters.

Watching values

If you select the menu option Build->Debugger->Dump, then the current settings of the local variables are
displayed in the debug window.

3: main[l] locals ;I
Hethod arguments:
Local wariables:
count = 0
end = 2
main[1l] |
< [+ Build s Output . Debug 4 FindinFies 1 5 FindinFiles2 7 [ 4] *

Unfortunately, there seems to be no mechanism for inspecting instance fields.
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If you select the menu option Build->Debugger->Where, the debug window shows the call stack. For example, the
following call stack shows that the WordTest.main method called the Word.countSyllables method.

count = 0 -
end = 2 -J
main[l] where

[1] Word.countSyllables (Word.jawa:43)

[2] WordTe=st . main (WordTest.jawa:18)

main[l]
b
<[ ]5Build 3, Output s Debug 4 Findin Files 1 % FindinFiles2 7 ] «| r

Stopping the debugger

When the program has completed, the debugger stops automatically. When you want to terminate a debugging
session without running the program to the end, select the menu option Tools->Stop tool.
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